Инструкции к применению

Платформа Mikrotik
Ответить
kaktatak
Сообщения: 42
Зарегистрирован: Пн фев 15, 2010 3:04 pm

Инструкции к применению

Сообщение kaktatak » Ср мар 27, 2013 3:30 pm

последнее время очень часто попадаются и тут и на локал.коме темы, в которых разные люди обвиняют авторов биллинга, в том что инструкции доступные в общем доступе (вики) очень не информативные. Что мол нельзя так просто взять скопировать с вики вставить в консоль и чтобы оно заработало сразу и без проблем. Скажу сразу, что я знаком с абиллс уже давненько, первый я с ним познакомился когда устроился в сеть, использовали коммерческую версию. В начале был нас + абиллс на одном сервере, использовали впн авторизацию. дальше по необходимости разнесли биллинг и нас на две разные машины. на НАС(сервер доступа) был установлен микротик роутерОС, на тот момент помоему была версия 3.30 еще. Настраивалось это все Asmodеus'ом. все время пока пользовались коммерческой версией и поддержкой, без проблем решались практически все вопросы. очень много по телефону, очень много в аське.... да может какието вопросы остаются либо без решения, либо долгое время решаются, но все таки большая часть вопросов остались с ответом и решением.
На данный момент я использую бесплатно доступную версию, потому что люди, которым я помогал интегрировать абиллс, не всегда готовы оплатить установку коммерческой версии... но с теми задачами, которые им нужны, бесплатная версия вполне справляется, а чего не хватает покупалось отдельно в модулях, которые отлично сочетаются и с бесплатной версией)

Основная моя практика это абиллс на Freebsd + сервера доступа на серверах под управлением RouterOS от Mikrotik. в качестве аторизации пользователей - или PPPoE или PPtP. потому что сети построены с минимальными затратами на оборудование)

установка самой биллинговой системы на сервер с FreeBSD(установленной минимальной версией) не составляет особого труда, инструкции доступные в вики http://abills.net.ua/wiki/doku.php/abil ... freebsd:ru и http://abills.net.ua/wiki/doku.php/abil ... install:ru вполне для этого подходят. Они даже подходят для того, чтобы скопировал вставил в консоль нажал этнер и ждешь результата. иногда приходится включать внимательность, когда пытаешься установить какой либо пакет, в команде(которую скопировал) указана версия, а ее нет в системе, нужно просто подправить под доступную у Вас.
После того как у Вас есть установленный абиллс, вы свободно заходите в админку или клиентскую статистику, можно продолжать знакомство и производить настройку доступа, тарифов и тп.

Мануал для подключения микротик в качестве сервера доступа тоже вполне детальная. после внимательного чтения, и небольшого понимания, что должно получиться в конце, можно настроить копируя и вставляя все команды. единственное что нужно вписывать свои апишники в нужные места.
Создание сертификата
Сделайте сертификат пустым паролем.

Код: Выделить всё

# /usr/abills/misc/certs_create.sh ssh abills_admin -UPLOAD_FTP admin@10.20.1.1
выполняется на сервере с абиллс. admin - логин для доступа на микротик, 10.20.1.1 адрес микротик который видит сервер с абиллс.
Mikrotik PPPoE/PPTP
Radius
Через консоль

Код: Выделить всё

/radius add address=192.168.101.17 secret=radsecret service=ppp
/radius incoming set accept=yes port=1700 
192.168.101.17 - адрес сервера с радиус сервером( в нашем случае это там же где находится абиллс)
PPP
Через консоль

Код: Выделить всё

/ppp aaa set accounting=yes use-radius=yes interim-update=300
/ppp profile set default local-address=192.168.101.10
192.168.101.10 - адрес сервера, который будет виден у клиентов в состоянии соединения(тунеля впн или рррое) как адрес сервера. Для рррое некотрые рекомендуют указывать его такойже как на сетевом интерфейсе смотрящим в мир. Не рекомендую писать сюда адрес с сетевой которая смотрит к вам в сеть( для линукс клиентов проблематично работать с адресами доступными и по сети и по тунелю)

впринципе и все. прописываем в /usr/local/radiusd/etc/raddb/clients.conf

client 127.0.0.1 {
secret = radsecret
shortname = shorrname
}
вместо 127.0.0.1 указываем адрес сервера доступа, который видит сервер с абиллс.
Заводим в вебке абиллса новый сервер доступа, прописываем пул адресов, которые будут выдаваться абонентам на тунели.... наслаждаемся.
Вроде ничего не пропустил.
Если все равно не понятно, можете писать, попробую объяснить с учетом ваших адресов и данных, которые вы предоставите.
Сюда же буду писать, доп информацию, как я что делал)

Makioro
Сообщения: 241
Зарегистрирован: Ср апр 27, 2011 11:09 am

Re: Инструкции к применению

Сообщение Makioro » Пт апр 12, 2013 6:35 am

Вопросы по Mikrotik + DHCP + Option82 + proxy-arp задавать?

bledboy
Сообщения: 12
Зарегистрирован: Сб мар 29, 2014 5:24 pm

Re: Инструкции к применению

Сообщение bledboy » Сб мар 29, 2014 9:39 pm

Как настроить связку abills + mikrotik без радиус сервера. Я шейперы не использую. Как сделать чтобы создавая в abills клиента - его айпи и принадлежность адрес-листу передавались микротику?

~AsmodeuS~
Site Admin
Сообщения: 5706
Зарегистрирован: Пт янв 28, 2005 3:11 pm
Контактная информация:

Re: Инструкции к применению

Сообщение ~AsmodeuS~ » Вс мар 30, 2014 8:12 am

Makioro писал(а):Вопросы по Mikrotik + DHCP + Option82 + proxy-arp задавать?

http://abills.net.ua/wiki/doku.php/abil ... rotik_dhcp

~AsmodeuS~
Site Admin
Сообщения: 5706
Зарегистрирован: Пт янв 28, 2005 3:11 pm
Контактная информация:

Re: Инструкции к применению

Сообщение ~AsmodeuS~ » Вс мар 30, 2014 8:13 am

bledboy писал(а):Как настроить связку abills + mikrotik без радиус сервера. Я шейперы не использую. Как сделать чтобы создавая в abills клиента - его айпи и принадлежность адрес-листу передавались микротику?
http://abills.net.ua/wiki/doku.php/abil ... ka_trafika

bledboy
Сообщения: 12
Зарегистрирован: Сб мар 29, 2014 5:24 pm

Re: Инструкции к применению

Сообщение bledboy » Вс мар 30, 2014 3:08 pm

Стоит задача - чтобы при создании пользователей в абилсе - микротику в адрес лист попадали данные IP(айпи клиента) и inet (имя правила): ip firewall address-list add list=inet address=10.127.114.254
А при негативном балансе значение list=inet заменялось на list=blok. Нарезка скорости и подсчет трафика не нужны

В файле config.pl я добавил:

@MODULES = ('Dv',
'Ipn',
'Msgs',
'Sqlcmd');
#Ipn
$conf{IPN_FW_START_RULE}="/usr/bin/sudo /usr/abills/libexec/linkupdown mikrotik up - %LOGIN %IP NAS_HOST=134.249.139.212 NAS_ADMIN=abills_admin". ' > /dev/null 2>&1';

$conf{IPN_FW_STOP_RULE}="/usr/bin/sudo /usr/abills/libexec/linkupdown mikrotik down - %LOGIN %IP NAS_HOST=134.249.139.212 NAS_ADMIN=abills_admin". ' > /dev/null 2>&1';

134.249.139.212 - айпи микротика

Результаты на последней картинке. То есть в адрес лист попадает только то что я вбиваю в настройках "Классы трафика"
Вложения
1.png
1
1.png (53.8 КБ) 6301 просмотр
2.png
2
2.png (81.33 КБ) 6301 просмотр
3.png
3
3.png (57.29 КБ) 6301 просмотр

~AsmodeuS~
Site Admin
Сообщения: 5706
Зарегистрирован: Пт янв 28, 2005 3:11 pm
Контактная информация:

Re: Инструкции к применению

Сообщение ~AsmodeuS~ » Пн мар 31, 2014 8:51 am

bledboy писал(а):Стоит задача - чтобы при создании пользователей в абилсе - микротику в адрес лист попадали данные IP(айпи клиента) и inet (имя правила): ip firewall address-list add list=inet address=10.127.114.254
А при негативном балансе значение list=inet заменялось на list=blok. Нарезка скорости и подсчет трафика не нужны

#Ipn
$conf{IPN_FW_START_RULE}="/usr/bin/sudo /usr/abills/libexec/linkupdown mikrotik up - %LOGIN %IP NAS_HOST=134.249.139.212 NAS_ADMIN=abills_admin". ' > /dev/null 2>&1';

$conf{IPN_FW_STOP_RULE}="/usr/bin/sudo /usr/abills/libexec/linkupdown mikrotik down - %LOGIN %IP NAS_HOST=134.249.139.212 NAS_ADMIN=abills_admin". ' > /dev/null 2>&1';
Для открытия доступа пишите програму которая будет добавлять на микротик ип и вставляете её в $conf{IPN_FW_START_RULE}

и программу которая будет отключать и вставляете её в $conf{IPN_FW_STOP_RULE}

все кто не в списке разрешённых блокируете

bledboy
Сообщения: 12
Зарегистрирован: Сб мар 29, 2014 5:24 pm

Re: Инструкции к применению

Сообщение bledboy » Пн апр 07, 2014 6:40 am

~AsmodeuS~ писал(а):
bledboy писал(а):Стоит задача - чтобы при создании пользователей в абилсе - микротику в адрес лист попадали данные IP(айпи клиента) и inet (имя правила): ip firewall address-list add list=inet address=10.127.114.254
А при негативном балансе значение list=inet заменялось на list=blok. Нарезка скорости и подсчет трафика не нужны

#Ipn
$conf{IPN_FW_START_RULE}="/usr/bin/sudo /usr/abills/libexec/linkupdown mikrotik up - %LOGIN %IP NAS_HOST=134.249.139.212 NAS_ADMIN=abills_admin". ' > /dev/null 2>&1';

$conf{IPN_FW_STOP_RULE}="/usr/bin/sudo /usr/abills/libexec/linkupdown mikrotik down - %LOGIN %IP NAS_HOST=134.249.139.212 NAS_ADMIN=abills_admin". ' > /dev/null 2>&1';
Для открытия доступа пишите програму которая будет добавлять на микротик ип и вставляете её в $conf{IPN_FW_START_RULE}

и программу которая будет отключать и вставляете её в $conf{IPN_FW_STOP_RULE}

все кто не в списке разрешённых блокируете
Для этого, на сколько я понял, радиус можно не настраивать? Только ssh будет задействован?

~AsmodeuS~
Site Admin
Сообщения: 5706
Зарегистрирован: Пт янв 28, 2005 3:11 pm
Контактная информация:

Re: Инструкции к применению

Сообщение ~AsmodeuS~ » Пн апр 07, 2014 7:14 am

bledboy писал(а):
~AsmodeuS~ писал(а):
bledboy писал(а):Стоит задача - чтобы при создании пользователей в абилсе - микротику в адрес лист попадали данные IP(айпи клиента) и inet (имя правила): ip firewall address-list add list=inet address=10.127.114.254
А при негативном балансе значение list=inet заменялось на list=blok. Нарезка скорости и подсчет трафика не нужны

#Ipn
$conf{IPN_FW_START_RULE}="/usr/bin/sudo /usr/abills/libexec/linkupdown mikrotik up - %LOGIN %IP NAS_HOST=134.249.139.212 NAS_ADMIN=abills_admin". ' > /dev/null 2>&1';

$conf{IPN_FW_STOP_RULE}="/usr/bin/sudo /usr/abills/libexec/linkupdown mikrotik down - %LOGIN %IP NAS_HOST=134.249.139.212 NAS_ADMIN=abills_admin". ' > /dev/null 2>&1';
Для открытия доступа пишите програму которая будет добавлять на микротик ип и вставляете её в $conf{IPN_FW_START_RULE}

и программу которая будет отключать и вставляете её в $conf{IPN_FW_STOP_RULE}

все кто не в списке разрешённых блокируете
Для этого, на сколько я понял, радиус можно не настраивать? Только ssh будет задействован?
да

Ответить